Se connecter avec
S'enregistrer | Connectez-vous
Votre question

formule excel "si...." m'énerve!!!!

Dernière réponse : dans Windows
Partagez
4 Mai 2004 18:25:23

Hello,

je suis bloqué sur une fonction, car peu de connaissance sur Excel, mais peut être que vous allez pouvoir m'aider!!!

En gros voilà :

J'ai une cellule = B8 qui correspond à un chiffre entier positif
oje cherche les formules à mettre poru A et B :
Cellule A : attend un chiffre entier positif
Cellule B : attend un chiffre entier positif


Si B8 est compris entre 001 et 19 alors A=0 et B=0
Si B8 est compris entre 020 et 29 alors A=1 et B=0
Si B8 est compris entre 030 et 49 alors A=0 et B=1
Si B8 est compris entre 050 et 59 alors A=1 et B=1
Si B8 est compris entre 060 et 79 alors A=0 et B=2
Si B8 est compris entre 080 et 89 alors A=1 et B=2
Si B8 est compris entre 090 et 109 alors A=0 et B=3
Si B8 est compris entre 110 et 119 alors A=1 et B=3
Si B8 est compris entre 120 et 139 alors A=0 et B=4

jusqu'à 299!!!

comment faire!

Autres pages sur : formule excel enerve

4 Mai 2004 18:28:42

je présise que je suis une burne sous excel, alors si qqn peut me filer la formule à balancer directement, ce serait....... merveilleux!
4 Mai 2004 18:32:04

A : si(B8<20;0;si(B8<30;1;si(B8<50;0;si(b8<60;1;si(... et à la fin : si(B8<290 (ou 280, je sais pas);0 (ou 1, je sais pas non +); 1 (ou 0 ^^)
B : si(B8<30<0;si(B8<60;1;si(B8<90;2;si(B8<120;3;si(B8<140;4;si(B8<180;si(... et à la fin : si (B8 <270 (ou 280);(ton chiffre);(le même chiffre +1)


voilà :D 
t'as + qu'à compléter en suivant le shéma, et Excel rajoutera les parenthèses de fermeture tout seul à la fin
Contenus similaires
4 Mai 2004 18:53:54

merci bcp, je teste demain, car là, je me barre du taf ;) 
4 Mai 2004 19:47:58

seulement 7 sous-conditions "si" possibles sous excel, non?
4 Mai 2004 20:07:50

oubli pas le = devant :whistle: 
5 Mai 2004 10:13:47

un mec m'a trouvé 1000 fois mieux!

A: =QUOTIENT(MOD(B8;30);20)
B: =QUOTIENT(B8;30)


[:aiua]
5 Mai 2004 10:22:40

connaissais pas ste forule [:spamafote]
17 Novembre 2004 18:51:59

salut je suis nouvelle ici g grave du mal sur une formule avec excel, g limpression ke t assez fort et ke tu poura suremen maider, stp sauve moi la vi en me disan ke tu c commen faire la moyenne de note avec des case vide tt ça avec des coefs.!!!! :( :( :( :( 

dans le genre faire (15*2)+(13*3)/(3+2) si les note 15 et 13 sont dans c case !
aide moi stppppp
14 Février 2007 11:53:53

Bonjour
Moi aussi j au un pb sur excel et je pense que vous pouver m aider a le résoudre!
J ai une colonne qui contient des ref(E) et ds la colonne d a coté (F)je voudrai mettre ce a quoi elles correspondent

Donc si E2 = 1036 mettre FR
si E2 = 2057 mettre UK
si E2 = 1034 mettre ES
si E2 =1040 mettre IT

Alors pour l instant j ai reussi a mettre FR ou sinon ja i demandé a mettre "Autre"
ce qui donne =SI(E2=1036;"FR";"Autre" )

Que faire pr le reste?

Merci d avance!
14 Février 2007 12:05:37

Il faut les imbriquer!

=SI(E2=1036;"FR";SI(E2=1040;"IT";SI(E2=1034;"ES";SI(E2=2057;"UK";"autre"))))
14 Février 2007 14:24:44

ca marche super!

merci magellan !!!
4 Octobre 2007 11:00:48

Bonjour
j'ai une question sur excel
j'ai des valeur 6 colonnes avec a chaque fois une colonne oui et une colonne non ( 3 fois)
et dans la 7 j'ai un resultat (chiffre) qui est diiférent en fonction des combinaison de oui et de non
j'ai fais une formule avec des si mais j'aimerai savoir s'il y en a une plus simple
merci d'avance
22 Novembre 2007 12:37:06

Bonjour,

Pourrais tu m'aider sur ce problème

1-1DXQJY CHANTIER NOVALEX A
1-1DXQJY CHANTIER NOVALEX B
1-1DXQJY CHANTIER NOVALEX C

J'aimerais une formule qui puisse me donner lors des doublons une indication comme A B C D E F
A étant l'original B C D E F doublons peux tu m'y aider stp ?