Se connecter avec
S'enregistrer | Connectez-vous
Votre question
Résolu

Réseau freebox + routeur Netgear

Tags :
  • Réseau local
  • Freebox
  • Réseau
Dernière réponse : dans Réseaux
Partagez
28 Avril 2010 20:04:07

Bonjour,

J'essai de mettre en réseau 6 PCs sous windows 7 64bits, avec à disposition un routeur Netgear WGR614 (4 ports) et une Freebox version 5 C (avec seulement 2 ports libres). Le tout en ethernet.

J'ai donc branché 4 PCs sur le routeur Netgear, lui même branché sur la freebox. Les 2 autres PCs sont branchés directement sur la Freebox.

Le problème : les 4 PCs sur le Netgear se voient entre eux, mais ne peuvent pas voir les 2 PCs qui sont sur la freebox. De même en sens inverse, les 2 PCs sur la freebox ne voient pas les PCs branchés sur le Netgear.

Par contre tout le monde a accès à internet, mais le but est de pouvoir partager des fichiers entre tous les PCs.

J'aimerais donc savoir comment faire pour n'avoir qu'un seul réseau et que tout le monde puisse communiquer ensemble, car pour le moment j'ai à priori 2 réseaux distincts, et je ne sais pas comment les relier.

Merci d'avance à ceux qui pouront m'aider !

Autres pages sur : reseau freebox routeur netgear

28 Avril 2010 20:20:19

Nyax_ a dit :
Bonjour,

J'essai de mettre en réseau 6 PCs sous windows 7 64bits, avec à disposition un routeur Netgear WGR614 (4 ports) et une Freebox version 5 C (avec seulement 2 ports libres). Le tout en ethernet.

J'ai donc branché 4 PCs sur le routeur Netgear, lui même branché sur la freebox. Les 2 autres PCs sont branchés directement sur la Freebox.

Le problème : les 4 PCs sur le Netgear se voient entre eux, mais ne peuvent pas voir les 2 PCs qui sont sur la freebox. De même en sens inverse, les 2 PCs sur la freebox ne voient pas les PCs branchés sur le Netgear.

Par contre tout le monde a accès à internet, mais le but est de pouvoir partager des fichiers entre tous les PCs.

J'aimerais donc savoir comment faire pour n'avoir qu'un seul réseau et que tout le monde puisse communiquer ensemble, car pour le moment j'ai à priori 2 réseaux distincts, et je ne sais pas comment les relier.

Merci d'avance à ceux qui pouront m'aider !


il faut mettre un switch apres le routeur
m
0
l
29 Avril 2010 10:49:24

Bonjour Nyax,

Je pense que le problème vient du fait que tu as dû mettre des adresses similaires sur tes 6 PC genre 192.168.0.xxx (255.255.255.0) ?

La meilleure solution serait de désactiver le routage sur ton routeur NetGear qui du coup ne serait plus qu'un simple switch.

Si ce n'est pas possible il faut :
- des adresses genre 192.168.0.xxx (255.255.255.0) pour les 4 PCs et le routeur NetGear
- des adresses genre 192.168.1.xxx (255.255.255.0) pour les 2 PCs sur la Freebox et pour la Freebox elle-même. Il faut aussi que ton routeur ai une adresse en 192.168.1.xxx.
m
0
l
Contenus similaires
29 Avril 2010 15:01:22

Merci pour vos réponses. En effet connecter tous les PCs au même swich serait le plus simple, mais je n'en ai pas, donc si c'est possible j'aimerais faire fonctionner le réseau avec le matériel dont je dispose déjà.

Quand je désactive le dhcp du routeur (je suppose que c'est ce que tu entends par "désactiver le routage"), j'obtiens des adresses étranges, comme : 169.254.35.26 avec 255.255.0.0 en masque de sous réseau.

Je n'y connais pas grand chose en réseau donc je ne sais pas du tout à quoi une adresse de ce type correspond. De plus, internet n'est plus accessible avec le dhcp désactivé.


Par contre avec le dhcp activé, j'ai bien des adresses comme tu dis, mais c'est inversé.

192.168.0.xxx pour les 2 PCs sur la Freebox, 192.168.0.1 pour la Freebox elle-même.
192.168.1.xxx pour les 4 PCs sur le routeur, 192.168.1.1 pour le routeur.
Tous les PCs ont 255.255.255.0 en masque de sous réseau.

Depuis n'importe quel PC j'ai une réponse lorsque je lance un ping vers un autre PC, donc la communication se fait bien.

Par contre j'ai beau chercher dans Windows, je ne trouve pas comment ne faire qu'un seul réseau pour tout le monde.
m
0
l

Meilleure solution

29 Avril 2010 21:29:38

tu as 2 réseaux ip différents , celui de la box et celui du netgear

achètes toi un switch (à 8 ports au moins), retire le routeur (et rends le si tu peux)
branche le switch sur la box et ce devrait être bon

il faut aussi dire à tous les pc que ce réseau est un réseau privé ou encore un réseau d'entreprise pour permettre aux pc's de communiquer

sur un réseau dit 'public', on ne peut pas communiquer entre les pc's
(si il y a moyens mais je veux rester simple ici)

ensuite il faut dire aux firewalls sur les pc's que ce sous-réseau est autorisé

et finalement on peut mettre l'une ou l'autre ressource en partage (sharing)
ne JAMAIS mettre tout le disque C: en partage !!!


====================

en restant comme tu es, il est possible de communiquer entre pc's d'un autre réseau en faisant:
. dans une dos-box : net use z: \\192.168.1.10\data
. 192.168.1.10 est l'adresse ip du pc qui partage une ressource appelée 'data'

. dans explorer : outils -> map disque réseau -> (en dessous de disque) entrer \\192.168.1.10\data


il se peut qu'il faille rajouter une route pour les pc's brancher sur la box
(j'avais bien dit qu'avoir un switch serait plus simple ;-) )


route ADD 192.168.1.0 MASK 255.255.255.0 192.168.2.13
. destination^ ^masque ^gateway
192.168.1.0 est le réseau derrière le netgear
192.168.2.13 est l'adresse 'wan' du netgear du côté de la box

bon, tu adaptes bien sur les adresses à celles que tu as chez toi

si la box et le netgear ont le même sous-réseau, ça va être la pagaille
partage
30 Avril 2010 00:17:24

Alors, en créant un lecteur réseau ça fonctionne, depuis les PCs sur le routeur, je peux accéder aux PCs qui sont sur la Freebox. Par contre dans l'autre sens ça ne fonctionne pas, j'en déduis que c'est là qu'il faut ajouter une "route", mais je ne comprend pas très bien le principe. C'est une commande DOS aussi ?

En tout cas, merci beaucoup pour votre aide.

Pour le moment le partage de fichiers ne peut se faire que dans un sens, mais c'est déjà beaucoup plus pratique pour travailler.
m
0
l
30 Avril 2010 07:44:47

Est-ce que tu ping bien les PCs derrière le routeur à partir des PCs branchés sur la box ?

Si oui alors ce n'est pas un problème de route.
m
0
l
30 Avril 2010 14:05:51

Mince, en fait non je ne peux pas "pinger" les PCs du routeur depuis ceux qui sont sur la box. Le ping ne fonctionne que dans l'autre sens, depuis un PC sur le routeur vers ceux sur la box.

Sinon, voici ce que j'ai avec ipconfig, desfois que ça puisse aider :

PC sur le routeur :

Adresse IPv4 192.168.1.xxx
Masque de sous-réseau 255.255.255.0
Passerelle par défaut 192.168.1.1
Serveur DHCP 192.168.1.1

PC sur la Freebox :

Adresse IPv4 192.168.0.xxx
Masque de sous-réseau 255.255.255.0
Passerelle par défaut 192.168.0.1
Serveur DHCP 192.168.0.1
Serveur DNS 212.27.40.241


Par rapport à ce qu'a dit Shaoul : "si la box et le netgear ont le même sous-réseau, ça va être la pagaille". J'ai essayé de changer le masque dans les paramètres du routeur, mais il se remet tout seul sur 255.255.255.0, je ne sais pas si je m'y prend de la bonne façon.
m
0
l
30 Avril 2010 19:54:43

c'est mon avis et je le partage, je suis persuadé qu'il y a un problème de routage (et c'est normal d'ailleurs). il pourra avoir (en plus) un problème de firewall (donc sur tous les pc's, vérifier que 192.168.0.0 et 192.168.1.0 - masque 255.255.255.0 sont bien acceptés ou marqués comme surs

oui, il faudra ajouter à la main les routes pour les pc's branchés sur la box
oui c'est une commande dos

il y a une chance d'éviter celà si on peut mettre la route sur la box même
mais là ça dépend tellement des boxes

1. déterminer l'adresse 'wan' du routeur
(aller sur l'interface web du routeur depuis les pc's branchés dessus, c'est une adresse du style 192.168.0.x où x n'est ni '0', ni '1' ni '255')

2. faire (dans la dos-box):
route ADD 192.168.1.0 MASK 255.255.255.0 192.168.0.x où 'x' est l'adresse wan du routeur

m
0
l
30 Avril 2010 23:29:16

Merci, j'ai suivi vos instructions :

Sur la box, l'adresse du routeur est 192.168.0.11, je peux accéder à son interface via cette adresse. J'ai mis cette adresse en IP fixe sur la box. Par contre je ne trouve pas comment mettre la route directement sur la box, je suis donc passé par le dos.

Donc sur un PC branché sur la box j'ai tapé : route ADD 192.168.1.0 MASK 255.255.255.0 192.168.0.11

Puis j'ai reçu un message "OK!". La route est bien affichée quand je fais un route PRINT.

Mais si je lance un ping vers un PC qui est sur le routeur en tapant par exemple 192.168.1.1 je n'ai aucune réponse. Je ne comprend pas, je fais quelque chose de travers ?


Au niveau du firewall, à priori ils sont bien configurés. J'ai essayé de tous les désactiver le temps de tester mais le résultat est le même.

J'ai aussi redémarré les PCs au cas où, sans amélioration.

Pour le routeur, il répond au ping depuis tous les PCs aussi bien connectés sur lui que sur la box.
m
0
l
1 Mai 2010 23:30:54

> 192.168.1.1
ce serait l'adresse 'LAN' du routeur non ?
ceci impose un demi-tour parfois mal implémenté
essaie plutôt l'adresse d'un des pc banchés sur le routeur (192.168.1.2 ou .3, ...)

au pire, tu installes 'wireshark' sur deux pc (un sur la box, un sur le routeur)
wireshark est un sniffer gratuit d'excellente qualité
ainsi (en lançant wireshark et la capture) on pourra voir si les paquets icmp (les pings) arrivent au pc cible, repartent vers le pc destination, ...

http://www.wireshark.org/download.html

juste un (gros) couac, wireshark (gratuit) ne marche pas en wireless (la version payante oui)
m
0
l
2 Mai 2010 02:34:18

Pour le ping, j'ai essayé aussi les 192.168.1.2, .3, .4 et .5, mais ça ne répond pas.

Sinon, la route disparaissait à chaque reboot, j'ai donc fait un "route -p ADD ..." pour la rendre permanente.

Je vais essayer wireshark. Tout est en ethernet donc la version gratuite suffira.


EDIT :

J'ai donc utilisé wireshark et effectué des pings.
Le PC sur le routeur a pour IP : 192.168.1.2. Le PC sur la box a pour IP : 192.168.0.12.

Si je ping depuis un PC sur le routeur vers un PC sur la box :

PC sur le routeur :
Source : 192.168.1.2 - Destination : 192.168.0.12 - Protocol : ICMP - Info : Echo (ping) request
Source : 192.168.0.12 - Destination : 192.168.1.2 - Protocol : ICMP - Info : Echo (ping) reply

PC sur la box :
Source : 192.168.0.11 - Destination : 192.168.0.12 - Protocol : ICMP - Info : Echo (ping) request
Source : 192.168.0.12 - Destination : 192.168.0.11 - Protocol : ICMP - Info : Echo (ping) reply

Si je ping depuis un PC sur la box vers un PC sur le routeur :

PC sur le routeur :
Aucun paquet n'arrive avec le protocole ICMP

PC sur la box :
Source : 192.168.0.12 - Destination : 192.168.1.2 - Protocol : ICMP - Info : Echo (ping) request
Et donc il n'y a pas de "reply".

Le PC qui est sur la box n'a l'air de voir que le routeur, et pas ce qu'il y a derrière.


Sinon, j'utilise VNC pour piloter à distance un PC qui est sur la box (il doit servir de serveur) et ça fonctionne. Depuis un PC sur le routeur je peux me connecter au serveur (celui qui a l'adresse 192.168.0.12) et le contrôler, donc il est bien possible de communiquer dans les 2 sens.
Sur le serveur, wireshark m'indique que les paquets VNC sont envoyés à 192.168.0.11, donc le routeur, alors qu'au final ils arrivent sur le PC 192.168.1.2.

Il doit bien être indiqué quelque part aux paquets de VNC qu'ils doivent se rendre sur le bon PC ?
m
0
l
2 Mai 2010 11:41:11

c'est très bizarre que le pc sur la box ne répond pas aux ping !!
(ça sent le firewall)

le fait qu'avec vnc tu puisse commander depuis un pc derrière le routeur un pc sur la box indique que le routage est bon (route add ...)

===================

autre chose à essayer (si possible sur ce routeur) mettre le routeur en mode 'bridge'. ainsi le routeur ne route plus et sera transparent
(désolé j'y ai pensé cette nuit seulement)

(il faudre rebooter les pc's sur le routeur ou bien faire ipconfig /renew pour qu'ils prennent la nouvelle adresse ip)
m
0
l
2 Mai 2010 15:15:11

J'ai vu que le routeur lui même possède un firewall. J'ai donc tenté de le désactiver temporairement, ainsi que le firewall de Windows sur les 2 PCs que j'essaye de faire communiquer, mais ça ne change rien du tout.
Donc à moins qu'il reste un firewall caché quelque par, normalement rien ne doit bloquer.

Pour le mode bridge, je ne le trouve pas dans les paramètres du routeur.
m
0
l
12 Mai 2010 02:25:59

Meilleure réponse sélectionnée par Nyax_.
m
0
l
12 Mai 2010 02:27:36

Bon, problème toujours pas résolu, je ne comprend vraiment pas.

Mais bref, on va se contenter de ça pour bosser, les PCs peuvent communiquer "à moitié", ce qui est à peu près suffisant.

Merci surtout à shaoul, avec l'idée de la route et des disques réseaux on peut s'échanger des fichiers presque correctement.
m
0
l