Se connecter avec
S'enregistrer | Connectez-vous
Votre question

Formule excel 2003 : multiples conditions SI

Tags :
  • Microsoft Excel
  • Windows
Dernière réponse : dans Windows
Partagez
5 Décembre 2012 07:57:04

bonjour
je ne trouve pas la formule, j'ai essayé avec Si mais cela ne fonctionne pas
ce que je recherche : j'ai en A une heure d'arrivée en B une heure de départ et en c le temps de présence
si c <= 9 le prix est de 2.97
si c > 9 le prix est le 3.30
si c > 10 le prix est de 3.63
si c > 11 le prix est de 3.96
merci de me guider

Autres pages sur : formule excel 2003 multiples conditions

5 Décembre 2012 10:08:54

As-tu essayé de schématiser ton problème. Pose-le sous forme d'arbre. Pour la première condition, tu détermines ce qui se passe quand c'est vrai et quand c'est faux jusqu'à la dernière, ce qui devrait donner un truc comme ça :

=SI(C<=9;2.97;SI(C>9;3.30;SI(C>10;3.63;3.96)))
m
0
l
5 Décembre 2012 13:13:42

cela ne fonctionne pas il me met toujours 2,97 même si 10:00 h
m
0
l
Contenus similaires
5 Décembre 2012 13:47:30

Celle-ci devrait être mieux:
=SI(C>9;SI(C>10;SI(C>11;3.96;3.63);3.30);2.97)
m
0
l
5 Décembre 2012 17:14:48

  1. =SI(A10>=11;3,96;(SI(A10>=10;3,63;SI(A10>9;3,3;2,97))))
où A10 est la cellule
m
0
l