Se connecter avec
S'enregistrer | Connectez-vous
Votre question

Excel Formule SI imbriquer

Tags :
  • Windows
  • Microsoft Excel
  • formule
  • Logiciels
  • Programmation
Dernière réponse : dans Programmation
Partagez
15 Janvier 2013 21:25:01

Salut

=SI(D2="X";K2=0;SI(E2="X";K2="1";K2="Merci de placer X dans une des case"))

La formule ci-dessus bug et je comprend pas pourquoi !

Si je place un "X" dans la cellule D2 cela fonction mais je place un "X" dans la cellule E2, c'est parfois Vrai parfois Faux

mais dans tous les cas K2 ne resoit aucune valeur 0/1/ "Merci de placer X dans une des case"

J'ai du rater quelque chose, mais quoi ?

A+ Merci

Autres pages sur : excel formule imbriquer

16 Janvier 2013 14:44:36

Ta formule ne peut pas fonctionner... :/ 

J'imagine que tu veux donner une valeur à K2 en fonction de la valeur de D2 et E2?

Tu ne peux pas lui affecter une valeur de cette façon...

Tu dois utiliser la formule suivante dans la case K2:

=SI(D2="X";"0";SI(E2="X";"1";"Merci de placer X dans une des cases"))

Une remarque: si les deux cases sont cochées, K2 contiendra 0: c'est bien le comportement attendu?
m
0
l
17 Janvier 2013 22:44:44

Merci Storos

J'ai effectivement vue ou étais mon erreur, après avoir creusé hier soir ! et j'ai vue qu'en replacent les élément de la formul comme y faut cela marche !



pour k2=0 et bien attendu oui est non j'aurais préférer une 3ème possibilité tu style" il n'est pas possible de cocher deux cases "
mais bon soit je ferais un test supémentaire soit je ne sais pas !

mais si tu as une solution je suis preneur :-)

Merci a+

m
0
l
Contenus similaires
18 Janvier 2013 10:27:59

Facile:

=SI(ET(D2="X";E2="X");"Merci de ne cocher qu'une seule case";SI(D2="X";"0";SI(E2="X";"1";"Merci de placer X dans une des cases")))

Basique, mais efficace... ;) 
m
0
l
20 Janvier 2013 18:15:43

=SI(ET(E3=VRAI;0;SI(G3=VRAI;1;SI(I3=VRAI;2;SI(K3=VRAI;3;SI(M3=VRAI;4;SI(O3=VRAI;5;"Vide");"Merci de ne cocher qu'une seul case"))))))

j'ai un message d'erreur

"Vous avez tapé un nombre trop important d'arguments pour cette fonction."

Merci a+
m
0
l
a b L Programmation
21 Janvier 2013 16:08:20

Salut,

Revois ta formule !

Dans un éditeur de de texte, ajoute des retour-chariot, et indente ton œuvre. Tu verras mieux ton problème.
m
0
l
21 Janvier 2013 16:38:58

J'ajouterai juste qu'un "ET" avec un argument en dur à "0" ne sera pas d'une grande utilité... :D 

Les formules Excel sont simples à utiliser... avec un peu de rigueur... ;) 
m
0
l
21 Janvier 2013 20:02:25

Là les mec je ne trouve pas je de passé près 1 heure dessus et je ne trouve pas !

j'ai utilisé notepad ++ le nombre de paranthèse est bon !
je gallère grave la dessus !!!
a+
m
0
l
21 Janvier 2013 21:46:51

j'ai tester cela mais c'est pas viable


=SI(ET(E3=VRAI;G3=FAUX;I3=FAUX;K3=FAUX;M3=FAUX;O3=FAUX);0;
SI(ET(E3=FAUX;G3=VRAI;I3=FAUX;K3=FAUX;M3=FAUX;O3=FAUX);
SI(ET(E3=FAUX;G3=FAUX;I3=VRAI;K3=FAUX;M3=FAUX;O3=FAUX);
SI(ET(E3=FAUX;G3=FAUX;I3=FAUX;K3=VRAI;M3=FAUX;O3=FAUX);
SI(ET(E3=FAUX;G3=FAUX;I3=FAUX;K3=FAUX;M3=VRAI;O3=FAUX);
SI(ET(E3=FAUX;G3=FAUX;I3=FAUX;K3=FAUX;M3=FAUX;O3=VRAI);
2;"Une seul coche par ligne"))
m
0
l
22 Janvier 2013 10:18:35

J'imagine que tu veux faire ça:

=SI(ET(E3="X";G3="";I3="";K3="";M3="";O3="");0;SI(OU(ET(E3="";G3="X";I3="";K3="";M3="";O3="");ET(E3="";G3="";I3="X";K3="";M3="";O3="");ET(E3="";G3="";I3="";K3="X";M3="";O3="");ET(E3="";G3="";I3="";K3="";M3="X";O3="");ET(E3="";G3="";I3="";K3="";M3="";O3="X"));2;"Une seul coche par ligne"))

Évidemment, ce serait plus léger si Excel acceptait le XOR... :D 
m
0
l
a b L Programmation
22 Janvier 2013 14:18:53

Oki. Alors on arrête les conneries et on utilise un SOMME.SI().

:sol: 
m
0
l
22 Janvier 2013 15:47:24

Le somme.si() est très chouette, mais seulement si on a une valeur à mettre en face de chaque "X"... :/ 

Ici, je ne pense pas que ce soit le cas. :spamafote: 

Ou si? Pour le savoir il faudrait que thore nous en dise plus sur ce qu'il fait exactement... :) 
m
0
l
a b L Programmation
22 Janvier 2013 16:43:34

Mouhais. :/ 

Citation :
Une seul (sic) coche par ligne


On veut vérifier qu'il n'y a qu'une seule coche, un X, par ligne. Soit.
Alors, d'abord on n'écrit pas B = VRAI mais juste B !
Ensuite, on ne va pas s'en servir :o  :D 

  1. =SI(MAJUSCULE(SUPPRESPACE(CONCATENER(E3;G3;I3;K3;M3;O3)))<>"X";"Arhgggg! Faut une coche là, et une seule, merci";"Oki")

?
m
0
l
22 Janvier 2013 20:33:36

Oupss j'ai oublier de vous dir une chose
J'ai changer queque chose a la place des X j'ai utilisé les cases a cochés

comme exemple que j'ai touver sur ce site "http://sonle-codesnippets.blogspot.fr/2009/11/insert-ch..."


cela me fait que j'ai :
Ligne "2" ma ligne de titre/entête de colonne
---
colone "D" la colone de case a cocher dont le resulta tu cocher vas en colonne "E" "VRAI" ou "FAUX"
la colone E seras cacher une un fois que cela seras fini
---
il en vas de même jusqu'au colone N O (inclus)
la colone P c'est les dépendances
colonne Q c'est le viveau de dépendances
colonne R c'est "Valeur" la ou se trouve la formule en question

et donc du coup je test plus les x mais les "vrai" ou "faux"
a+



m
0
l
23 Janvier 2013 10:19:06

zeb a dit :
  1. =SI(MAJUSCULE(SUPPRESPACE(CONCATENER(E3;G3;I3;K3;M3;O3)))<>"X";"Arhgggg! Faut une coche là, et une seule, merci";"Oki")

?

Bien pensé: j'aime beaucoup! :) 

Mais malheureusement il n'y a plus de "X"... :/ 

Alors je propose ceci:


  1. =SI(NB.SI(E3:O3;VRAI)<>1;"Une des cases, et une seule, doit être cochée!";SI(E3;0;2))



C'est plutôt cool, non? :D 

Seul souci: je teste toute la plage de E à O, donc il ne faut pas que les cases intermédiaire contiennent "VRAI" ou "FAUX"... :/ 

Cela ne devrait pas être un problème, mais au cas où je cherche une solution pour remplacer la plage par des cellules individuelles... ;) 

m
0
l
a b L Programmation
23 Janvier 2013 11:41:56

J'avais écris SOMME.SI(). C'est bien évidemment à NB.SI() que je pensais.

Bravo mon cochon !
m
0
l
23 Janvier 2013 13:45:33

:jap: 
m
0
l
25 Janvier 2013 11:57:59

Thore? tu as réussi à faire ce que tu voulais? Nous avons été utiles?
m
0
l
28 Janvier 2013 20:28:41

Storos a dit :
zeb a dit :
  1. =SI(MAJUSCULE(SUPPRESPACE(CONCATENER(E3;G3;I3;K3;M3;O3)))<>"X";"Arhgggg! Faut une coche là, et une seule, merci";"Oki")

?

Bien pensé: j'aime beaucoup! :) 

Mais malheureusement il n'y a plus de "X"... :/ 

Alors je propose ceci:


  1. =SI(NB.SI(E3:O3;VRAI)<>1;"Une des cases, et une seule, doit être cochée!";SI(E3;0;2))



C'est plutôt cool, non? :D 

Seul souci: je teste toute la plage de E à O, donc il ne faut pas que les cases intermédiaire contiennent "VRAI" ou "FAUX"... :/ 

Cela ne devrait pas être un problème, mais au cas où je cherche une solution pour remplacer la plage par des cellules individuelles... ;) 



Après que que jour je me replonge de dans !
et la formule
=SI(NB.SI(E3:o 3;VRAI)<>1;"Une des cases, et une seule, doit être cochée!";SI(E3;0;2))
cela ne fonctionne pas mais je recherche d'ou cela viens
j'ai supprimer mes colone qui Vrai \ faux mais pas c'est toujours pas bon
Je cherche je vais bien finir par trouver !!!
a+

m
0
l
28 Janvier 2013 21:02:13

C'est normal que ça ne fonctionne pas!

Pourquoi est-ce que tu as retiré le
  1. :O3
de fin de plage dans le nb.si? :heink: 

Tout ce que tu avais à faire était de recopier ma ligne de code! :spamafote: 
m
0
l