Votre question
Résolu

windows se trompe sur ma RAM?

Tags :
  • Windows
  • RAM
  • Mémoires
Dernière réponse : dans Mémoires
6 Février 2018 16:16:40

Bonjour,

je suis de nouveau un peu perdu...
j'avais 2 barettes de 2Go de RAM, donc 4Go au total
J'en ai installé 2 nouvelles de 2Go chacune

J'ai démarré mon pc sans prob.

Une fois dans windows, il a indiqué 8Go comme de fait, mais, après reboot, il indique seulement 6Go de RAM alors que speccy et CPU-Z m'indiquent tous les deux 8Go.

Est-ce que vous auriez une idée pour laquelle le nombre indiqué est différent et de ce que je pourrais faire svp ?

Merci d'avance,

Stéph

Autres pages sur : windows trompe ram

7 Février 2018 18:58:52

Hello,
qu'y a t'il dans msconfig/démarrer/options avancées stp ?
m
0
l
7 Février 2018 20:18:22

oups désolé, j'ai oublié de clôturer le message, je n'ai plus ce problème.
Après avoir reboot une fois de plus, il a fini par indiqué le bon nombre de RAM et il n'y a plus eu de prob.

Et sinon, dans msconfig (que je ne connaissais pas, merci :) ) il indique bien maintenant 8192

Merci tout de même d'avoir voulu m'aider :) 
m
0
l
Contenus similaires
9 Février 2018 09:51:03

Ah zut mon message d'hier ne s'est pas envoyé il me semble.
Je reprends donc ...

Je suis allé trop vite en disant que le problème était résolu.
En effet, maintenant, lorsque je démarre le pc, il m'indique bien les 8 Go mais après quelques temps de fonctionnement (1h environ), paf, il me fait le coup de la panne ...
çàd un écran bleu et un reboot. Je ne suis pas sûr du message lors de l'écran bleu, il me semble qu'il parle d'un problème de traitement de thread ou quelque chose comme ça.
Et après ce reboot, il ne m'indique plus que 6Go de RAM.
Lorsque je fait un reboot manuel, il m'indique de nouveau les 8 jusqu'à ce qu'il replante de nouveau.

Entre-temps, je me suis rendu compte en trouvant et en lisant le manuel de ma cm qu'il ne fallait pas mettre les RAM dans n'importe quel slot si on en a seulement 4 sur les 6 possibles. J'ai donc adapté correctement, mais, le problème subsiste.

Bref, je sais maintenant que windows a raison, speccy aussi puisque j'avais mal lu ... il indique 8Go de mémoire virtuelle mais seulement 6 de physique lorsque le pb se présente. Quand tout va bien, il indique 8Go physique comme windows.

Mais, ce que je ne sais pas, c'est pourquoi ce problème subvient :( 
m
0
l
9 Février 2018 11:11:51

Normalement, il ne doit pas y avoir de valeur indiquée pour la quantité de RAM dans le msconfig.
Si la case sur la gauche du titre "Mémoire maximale" est cochée, décoches la.
m
0
l
14 Février 2018 09:35:57

Hello !

Bon, malheureusement, je n'ai pas pu continuer ce test, je n'ai eût que des ennuis multiples depuis ces derniers jours.

Le pc ne s'éteignais plus correctement, à savoir qu'en cliquant sur "démarrer" puis "arrêter" (idem avec "redémarrer"), l'écran s'éteignais mais pas le reste. Je faisais donc un appui long sur le bouton power pour l'éteindre complètement.

Lorsque je voulais le rallumer, l'écran restait désespérément noir.
Le seul moyen s'était d'éteindre l'alimentation avec le bouton on/off, d'attendre quelques minutes, de remettre le courant et de redémarrer le pc et là ça fonctionnait jusqu'à ce que je l'éteigne.

hier soir, j'ai laissé l'alim éteinte et lorsque j'ai voulu boot le pc avant d'aller au boulot, rien ... La led de la carte mère est allumée, mais le pc ne s'allume plus.

je soupçonne un problème d'alim mais ca peut être aussi la cm qui foire.

m
0
l
14 Février 2018 18:16:52

Selon ce que tu expliques, l'alim pourrait être en cause.
Mais quel est le modèle exact et depuis quand est-il installé ?
m
0
l
14 Février 2018 20:31:06

Je penchais aussi pour un problème d’alimentation, mais ...
Lorsque je suis rentré, j'ai remis l'alim sur on et appuyé sur le bouton marche du pc, rien ne s'est passé mais le voyant rouge de la cm était bien allumé.
J'ai débranché les fils des pins power+ et power- pour tenter de démarrer "au tournevis" au cas où le bouton serait fautif, et, rien ...
mais ca a attiré mon attention sur le jumper et je me suis rendu compte que je l'avais mal remis :| <-- andouille spotted
Dès que je l'ai mis en place correctement, le pc a démarré comme un bond.

Par contre, je m'interroge ... le bouton du boitier fonctionne alors que je n'ai jamais rebrancher les pins power ...
Je me demande s'ils n'ont pas intervertis les inscriptions power et reset sur les fils du boitier ...

Quoiqu'il en soit, tout n'est pas rentré dans l'ordre pour autant.
Après environ 2h de bons et loyaux services durant lesquels j'ai surfé et un peu joué à minecraft, BSOD et paf "Memory managment".
J'ai l'impression que mon problème originel de barettes de RAM n'est pas rétabli totalement.
Par contre, contrairement à l'origine, après le reboot automatique, windows 10 m'indique bien les 8Go (testés positifs au memetest)

msconfig / demarrer / options avancees m'indique ceci :

m
0
l
14 Février 2018 20:37:49

Et j'ai passé un coup de "whocrashed" pour lire le dump qui m'indique :



Je vais donc me renseigner sur ce fameux "hardware.sys"
Mes composants de pc sont trop vieux pour trouver des maj adaptées à win 10 :( 

j'edit pour ajouter mes dernières constatations.

J'ai effectué le test de driver veryfier : tuto driver veryfier

Ensuite, j'ai lu les dump avec whocrashed et j'ai trouvé le driver incriminé : atikmpag.sys
Je n'ai eu que des soucis avec les pilotes ati, même avec win 7 et les drivers officiels de AMD.
Ici, je ne sais pas quoi faire pour remédier au problème...

voici ce que dit le dump :

On Wed 14-02-18 20:53:25 your computer crashed or a problem was reported
crash dump file: C:\Windows\Minidump\021418-6453-01.dmp
This was probably caused by the following module: atikmpag.sys (0xFFFFF8015D2101E8)
Bugcheck code: 0xC4 (0x2006, 0xFFFF80889CA12358, 0xFFFFF8015D2101E8, 0xFFFFE789FE4E6208)
Error: DRIVER_VERIFIER_DETECTED_VIOLATION
file path: C:\Windows\system32\drivers\atikmpag.sys
product: AMD driver
company: Advanced Micro Devices, Inc.
description: AMD multi-vendor Miniport Driver
Bug check description: This is the general bug check code for fatal errors found by Driver Verifier.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: atikmpag.sys (AMD multi-vendor Miniport Driver, Advanced Micro Devices, Inc.).
Google query: atikmpag.sys Advanced Micro Devices, Inc. DRIVER_VERIFIER_DETECTED_VIOLATION



On Wed 14-02-18 20:53:25 your computer crashed or a problem was reported
crash dump file: C:\Windows\MEMORY.DMP
This was probably caused by the following module: atikmpag.sys (0xFFFFF8015D2101E8)
Bugcheck code: 0xC4 (0x2006, 0xFFFF80889CA12358, 0xFFFFF8015D2101E8, 0xFFFFE789FE4E6208)
Error: DRIVER_VERIFIER_DETECTED_VIOLATION
file path: C:\Windows\system32\drivers\atikmpag.sys
product: AMD driver
company: Advanced Micro Devices, Inc.
description: AMD multi-vendor Miniport Driver
Bug check description: This is the general bug check code for fatal errors found by Driver Verifier.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: atikmpag.sys (AMD multi-vendor Miniport Driver, Advanced Micro Devices, Inc.).
Google query: atikmpag.sys Advanced Micro Devices, Inc. DRIVER_VERIFIER_DETECTED_VIOLATION
m
0
l
15 Février 2018 18:06:35

Le debug de 20h14 indique un problème hardware lié à la RAM.
Celui de 20h53 laisse penser à un problème de pilote de la CG.
Le problème de mémoire peut impacter le fonctionnement de la CG.

Pour assurer, autant faire un complet nettoyage des pilotes graphiques en supprimant ces pilotes avec DDU en mode sans échec. Puis réinstaller les derniers pilotes (pour la CG et l'OS concernés) à partir du site AMD. PIlotes à télécharger avant la manip DDU.
On élimine ainsi la question des pilotes graphiques à 99% de chance.

Le Memtest86+ doit faire au moins 3 passes (5 idéalement) et ne pas indiquer d'erreur.
m
0
l
15 Février 2018 19:14:45

Bonsoir et merci pour ta réponse

je vais chercher ce qu'est DDU mais le problème c'est que ma carte graphique n'a pas de drivers pour win10.
J'ai commandé une gtx 1050 qui devrait arriver samedi donc j'imagine que ca réglerait ce problème éventuel des drivers de la carte graphique ?

J'avais lu trop vite le dump de 20:14, je n'avais même pas vu le mot RAM, je m'étais arrêté sur "a third party driver".

Je sais que memtest a fait au moins 3 passes mais je ne suis plus certain du nombre exact.
Je vais le relancer au cas où.

Merci encore de ton aide :) 

A toutes fins utiles, je viens d'avoir un autre BSOD :

On Thu 15-02-18 19:29:01 your computer crashed or a problem was reported
crash dump file: C:\Windows\Minidump\021518-9390-01.dmp
This was probably caused by the following module: fltmgr.sys (0xFFFFF80AE412A13C)
Bugcheck code: 0x50 (0xFFFFCB15E93643F8, 0x0, 0xFFFFF80AE412A13C, 0x2)
Error: PAGE_FAULT_IN_NONPAGED_AREA
file path: C:\Windows\system32\drivers\fltmgr.sys
product: Système d’exploitation Microsoft® Windows®
company: Microsoft Corporation
description: Gestionnaire de filtres de système de fichiers Microsoft
Bug check description: This indicates that invalid system memory has been referenced.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
The crash took place in a file system driver. Since there is no other responsible driver detected, this could be pointing to a malfunctioning drive or corrupted disk. It's suggested that you run CHKDSK.



On Thu 15-02-18 19:29:01 your computer crashed or a problem was reported
crash dump file: C:\Windows\MEMORY.DMP
This was probably caused by the following module: aswmonflt.sys (aswMonFlt+0x355E)
Bugcheck code: 0x50 (0xFFFFCB15E93643F8, 0x0, 0xFFFFF80AE412A13C, 0x2)
Error: PAGE_FAULT_IN_NONPAGED_AREA
file path: C:\Windows\system32\drivers\aswmonflt.sys
product: Avast Antivirus
company: AVAST Software
description: Avast File System Minifilter for Windows 2003/Vista
Bug check description: This indicates that invalid system memory has been referenced.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: aswmonflt.sys (Avast File System Minifilter for Windows 2003/Vista, AVAST Software).
Google query: aswmonflt.sys AVAST Software PAGE_FAULT_IN_NONPAGED_AREA
m
0
l
16 Février 2018 09:50:49

Alors,
DDU, c'est ici : https://www.guru3d.com/files-details/display-driver-uni...
Il est fort probable que la nouvelle CG avec les bons drivers permettent de ne plus avoir le crash de 20h53.

Pour le bug Avast, vérifier que le programme de l'anti-virus est bien à jour.
Pour l'autre bug, si l'OS est installé sur un disque dur, tu peux lancer le CHKDSK (Check Disc) en ligne de commande (taper CMD dans la petite loupe de recherche de programmes en bas à gauche). A lancer en mode administrateur.
La commande est : chkdsk /F /R x: où x est la lettre du disque dur sur lequel se trouve Windows, généralement C: .
m
0
l
16 Février 2018 10:13:04

Bonjour foretg,

ok, merci beaucoup, je fais ça dès ce soir.

J'ai aussi essayé un test power supply OCCT mais il s'est arrêté au bout de 6 min à cause d'une surchauffe de ma cg (85°).

Est-ce que tu penses possible que mes blue screens surviennent à cause d'une instabilité du système due à une surchauffe de ma cg ?

Quoiqu'il en soit, on verra ce week-end si taxipost fait son boulot en me livrant ma nouvelle cg

Merci encore pour ton aide
m
0
l
16 Février 2018 10:15:41

Tout est possible malheureusement. Ceci dit, 85° n'est pas délirant surtout lors d'un OCCT... Mais déjà commence par t'assurer qu'effectivement les tensions mentionnées dans OCCT sont propres, parce qu'à elles seules elles peuvent provoquer des bizarreries pénibles à détecter.
m
0
l
16 Février 2018 11:03:07

Si on pouvait avoir la réponse à mon message du 14 Février 2018 18:16:52, ça aiderait.
m
0
l
16 Février 2018 11:37:56

oups effectivement, désolé

le pc est resté prendre la poussière durant quelques années, je l'ai nettoyé et redémarré.
C'est un i7-920 non oc sur une cm asus p6t se
Je mettrai le speccy ce soir pour plus d'infos

l'alim est une antec earthwatts EA-500D 500W

Sauf erreur de ma part, le tout a été monté par un ami en 2009 -2010

Magellan, merci pour l'info. Je vais me renseigner sur ces tensions parce que je n'y connais rien du tout pour l'instant. Est-ce que tu connaîtrais un bon tuto sur occt et tout ça stp ?

m
0
l
16 Février 2018 11:48:30

C'est un bloc très bien noté. A priori, pas de souci si ce n'est, éventuellement, son vieillissement. Normal.
En attente des résultats des manips proposées.
m
0
l
18 Février 2018 07:26:35

Bonjour et bon dimanche :) 

Alors, j'ai changé de carte graphique hier et je vais envoyer un mail de remerciement chez nvidia parce que mes oreilles sont soulagées ! Mes composants font aussi 10 a 20 degrés de moins.

J'avais utilisé ddu pour retirer les drivers de l'ancienne carte avant de mettre la nouvelle.

Avast était déjà a jour. Les checkdisk et sfc scannow n'ont rien signalés. J'utilise un ssd.

J'ai refait un memtest



J'ai ensuite retiré les 4 nouvelles barrettes de ram et laissé le pc allumé cette nuit pour lancer un occt power supply
Le test est allé jusqu'au bout et le pc n'a pas crash une seule fois

Occt a sorti un tas de graphique dans lesquels il indique toujours no error. Je suppose donc que mon alim est encore ok.

Et pour terminer, mon speccy :

Système d'exploitation
Windows 10 Famille 64-bit
Processeur
Intel Core i7 920 @ 2.67GHz 40 °C
Technologie Bloomfield 45nm
RAM
4,00 Go Canal-Double DDR3 @ 534 MHz (8-8-8-20)
Carte mère
ASUSTeK Computer INC. P6T SE (LGA1366) 32 °C
Graphiques
S24D300 (1920x1080@60Hz)
2047 MoNVIDIA GeForce GTX 1050 (ZOTAC International) 22 °C
Stockage
111GB SanDisk SDSSDX120GG25 ATA Device (SSD) 24 °C
931GB Western Digital WDC WD10EZEX-60WN4A0 ATA Device (SATA) 28 °C
m
0
l
18 Février 2018 09:23:01

Bonjour, tu dis au début du poste que tes problèmes sont apparus avec le rajout de ram donc il faudrait savoir si tes 4 barrettes sont identiques et si tu les a bien montées en dual-channel.
m
0
l

Meilleure solution

18 Février 2018 09:27:38

Bon, ben, ça à l'air d'aller mieux pour ce PC.

Pour les graphes OCCT, les principaux ici sont ceux des voltages : 12V, 5V et 3,3V.
Le "No error" signifie seulement que le test n'a pas été arrêté suite à un problème important du PC (typiquement, des températures trop élevées), mais n'indique pas la qualité des courants fournis que l'on trouvera sur les graphiques.
Upload les 3 graphes sur noelshack ou casimages par exemple.

Le Memtest86 a révélé des erreurs sur les tests 7-8-9 dès la première passe. Avant de jeter le manche après la cognée, il faut faire un test des barrettes une à une. Ce qui permettra de confirmer l'anomalie et d'identifier la(les) barrette(s) responsable(s).
partage
18 Février 2018 10:35:45

Re bonjour et merci pour les réponses.
Je vais refaire un memtest barrette par barrette
En attendant, voici les spécifications :

J'avais celles-ci :
http://www.corsair.com/en-us/cmx2gx3m1a1333c9

Et j'ai ajouté celles-ci:
http://www.corsair.com/en-gb/vs2gb1333d3

Étant donné les explications dans le manuel de la cm:




Je ne peux pas mettre les 2 vieilles barrettes dans le même Channel donc, si on considère vielle barrette = v et nouvelle barrette = n, je les avais disposées ainsi :

V n rien v rien n

Concernant occt :






m
0
l
18 Février 2018 11:05:50

Re,
pour les graphes OCCT, les courants fournis sont stables. Un peu juste sur le 5V et le 12V mais le test OCCT Power Suipply est assez lourd. Pour moi, c'est OK.

Les deux barretes devraient être compatbles ensemble : mêmes capacité, cadencement, voltage et latences.
La P6T SE est une CM qui gère le tripe canal mémoire (chipset X58). Avec 2 barrettes, on installe dans les slots A1 et B1. Soit, en partant du processeur, le deuxième slot et le 4ème slot.
m
0
l
18 Février 2018 11:39:31

ok ca me rassure pour l'alim alors merci bien :) 

Pour les barettes, j'avais omis de préciser que ce sont 4 barettes de 2 Go
je les ai donc placées dans les slots 1.2.4 et 6

Je ferai les memtest ce soir, j'imagine qu'on peut s'attendre à ce que l'une (ou les deux) nouvelle renvoie des erreurs
m
0
l
18 Février 2018 11:57:49

1-2-4-6 est en théorie OK.
A suivre les tests barrette par barrette.
m
0
l
18 Février 2018 16:28:34

Bon voilà, je ne dirais pas que j'ai fait des tests très très longs mais il trouve directement des erreurs pour l'un des deux nouvelles barettes et pas pour la 2éme ni pour les 2 anciennes barettes.

Actuellement, je tourne sur 3 barettes (6 go)

J'ai réalisé les tests sur le même slot
m
0
l
18 Février 2018 17:24:47

Memtest se trompe très rarement et des erreurs détectées à la première passe sont révélatrices.
3 barrettes, c'est pas plus mal vu que la CM est conçue pour 3 ou 6 DIMM (triple canal).
Bon, je crois que l'on est au bout de la somme des difficultés.
Reste à choisir le post qui, pour toi, représente la meilleure solution.
Bon dimanche.
m
0
l
18 Février 2018 17:38:51

Merci à toi pour ton aide en tout cas !
Très bon dimanche et à une prochaine fois
m
0
l