Accueil » Actualité » L’API Vulkan 1.0 va rater 2015

L’API Vulkan 1.0 va rater 2015

Image 1 : L'API Vulkan 1.0 va rater 2015

2015 fut l’année des API graphiques de bas niveau : DirectX 12 sous Windows 10, Metal sous OS X El Capitan et Vulkan sous Linux (et Android). Ah non, attendez ! Vulkan ne sera pas disponible cette année, mais uniquement en 2016.

Le Khronos Group, organisme qui veille sur le développement des API graphiques OpenGL, OpenCL et Vulkan, a annoncé qu’il manquerait son but et ne pourrait pas sortir Vulkan avant la fin 2015. Toutefois, le Khronos Group se veut rassurant et précise que Vulkan 1.0 est dans sa dernière ligne droite. Tout le travail d’écriture du standard est terminé, la spécification est complète d’un point de vue technique. Il reste à la relire d’un point de vue légal pour éviter de futurs problèmes pour ceux qui l’adopteraient.

Mais surtout, le Khronos Gourp attend que les premières implémentations de Vulkan soient prêtes. Plusieurs sociétés sont en train de mettre au point des produits et pilotes compatibles, de leur faire passer des tests de conformité. Ce n’est que lorsque ces tests seront positifs, que le standard Vulkan 1.0 sera officiellement publié. Reste voir si Vulkan sortira avant le retour de Spock sur les écrans.

STAR TREK SANS LIMITES – Bande-annonce officielle HD [VOST]