Accueil » Actualité » Thecus corrige le bug Shellshock sur ses NAS

Thecus corrige le bug Shellshock sur ses NAS

Image 1 : Thecus corrige le bug Shellshock sur ses NASDécouvert il y a quelques semaines seulement, le bug présent dans l’interpréteur en ligne de commande « Bash » (baptisé Shellshock mais également connu sous les références CVE-2014-6271, CVE-2014-7169, CVE-2014-7187 et CVE-2014-7186) va mettre du temps à être corrigé partout où il est utilisé, et il n’est même pas certain qu’il sera bel et bien totalement éradiqué un jour, tant les appareils qui font appel à Bash sont nombreux.

Certains constructeurs ont toutefois – plus ou moins rapidement – réagi en publiant des mises à jour des firmwares de leurs produits. C’est par exemple le cas de Thecus qui vient d’annoncer de nouveaux firmwares pour ses NAS sous ThecusOS5 x86 (v5.03.02.8), ThecusOS5 x64 (v2.05.06) et ThecusOS 6 (via un patch dédié, disponible pour les N2310, N4310, N2520, N2560, N4520 et N4560). Seul petit bémol : la mise à jour disponible pour le N2310 ne corrige pas totalement la vulnérabilité en question…

Voici la liste complète des NAS bénéficiant de cette mise à jour :

  • N16000 series / N12000 series / N8900 series
  • N10850 / N8850 / N6850
  • N8810 series / N7710 series
  • N8800PRO v2 / N7700 PRO v2
  • N7510 / N5550 / N4800 series / N4510U series / N2800
  • Thecus XXX series / 1U4600 / N0503 / N4200 series / N5500
  • N7700 / N7700SAS / N7700+ / N7700PRO
  • N8800 / N8800SAS / N8800+ / N8800PRO
  • N4100PRO