Se connecter avec
S'enregistrer | Connectez-vous
Votre question

[FireFox] Comment desactiver la recherche rapide ?

Tags :
  • Opensource
  • Internet
  • Windows
  • Firefox
Dernière réponse : dans Logiciels
Partagez
6 Décembre 2007 13:37:22

La question est le titre, j'ai un gros soucis depuis quelques versions de FF, soucis qui je pense doit etre partagé par pas mal de personne donc je me dis que quelqu'un a bien due trouver la solution.

Le probleme: en gros sous firefox dès que je veux tapper un apostrophe (') ca m'ouvre la recherche rapide au lieu de me le taper. J'ai eu beau fouiller je n'ai trouvé aucun moyen de desactiver la fonction ou de reassigner la touche. C'est tres genant sur un forum et le seul contournement trouvé quand je veux en tapper un est d'ouvrir la fenetre d'option de firefox et de la refermer aussi tot, et la etonnement plus de soucis, ce qui m'a vraiment fait pensé à un bug.
Mais en meme temps un bug qui se reproduit sur 3machines avec 3 installs differentes je doute que celà vienne de moi d'ou ce topic:
Comment desactiver la recherche rapide, ou comment réassigner la touche ?
Merci

Autres pages sur : firefox desactiver recherche rapide

6 Décembre 2007 14:46:29

Normalement, quand tu es dans une zone de saisie, l' (<-- là, j'en ai tapé un dans "Réponse rapide") apostrophe n'ouvre pas la recherche.

Pourquoi as-tu besoin de ça ?

Je viens de faire le tour de about:config, rien sur cet apostrophe :/ 

Sinon, une soluce radicale : FF c'est opensource. Tu récupères les sources, tu vires la gestion dui raccourcis {'} et tu recompiles le tout :D  :D 
6 Décembre 2007 14:50:49

NiahBoumPof is back a dit :
La question est le titre, j'ai un gros soucis depuis quelques versions de FF, soucis qui je pense doit etre partagé par pas mal de personne donc je me dis que quelqu'un a bien due trouver la solution.

Le probleme: en gros sous firefox dès que je veux tapper un apostrophe (') ca m'ouvre la recherche rapide au lieu de me le taper. J'ai eu beau fouiller je n'ai trouvé aucun moyen de desactiver la fonction ou de reassigner la touche. C'est tres genant sur un forum et le seul contournement trouvé quand je veux en tapper un est d'ouvrir la fenetre d'option de firefox et de la refermer aussi tot, et la etonnement plus de soucis, ce qui m'a vraiment fait pensé à un bug.
Mais en meme temps un bug qui se reproduit sur 3machines avec 3 installs differentes je doute que celà vienne de moi d'ou ce topic:
Comment desactiver la recherche rapide, ou comment réassigner la touche ?
Merci
Zarb, jamais vu ce bug

Tu as rechargé le fichier d'install depuis le site officiel de Mozilla ?

Sinon c'est sur quel type de clavier ? Portable ? Fixe ? dans les parametres regionnaux de ton OS, tu es bien sur un jeu de czractere FR ?
Contenus similaires
6 Décembre 2007 15:31:52

Heu.... c'est normal?

Ligne 18 du tableau: "Find As You Type Link"
http://www.mozilla.org/support/firefox/keyboard

Sinon, fermer Firefox, ctrl+alt+suppr, tuer le processus Firefox.exe si il est encore là puis retenter ta chance.
6 Décembre 2007 15:38:36

nozz a dit :
Heu.... c'est normal?

Ligne 18 du tableau: "Find As You Type Link"
http://www.mozilla.org/support/firefox/keyboard
effectivement c'est un raccourci clavier normal de FF

Test tout con : sur la zone de texte de la reponse rapide de PPC ca affiche bien ' à la saisie de al touche

Mais si on place le focus sur autre chose, genre en cliquant sur le corps du forum ou dans une news, ca ouvre bien la recherche rapide

D'un autre coté j'ai jamais appuyé sur ' lorsque je susi hors d'une zone de saisie [:ddr555]
6 Décembre 2007 15:59:45

Et en démarrant firefox en mode sans échec?

(firefox -safemode)
6 Décembre 2007 16:35:49

Spa un bug, c'est une fonctionnalité ! Une vraie, pour une fois. [:spamafote]
6 Décembre 2007 17:54:35

tu parles d'une fonctionalité, ca me pose plus de problemes qu'autre chose, vu ce que la recherche me sert :/ 

Et pour le coup du pointeur dans le champ de saisi j'ai deja essayé en effet (oui j'ai quand meme recherché avant de poster :D  desolé j'ai oublié de le preciser) et non rien a faire meme si le pointeur est dans le champ ca me le fait quand meme, jusqu'a la manip que j'ai detaillé plus haut.

Quand à l'option de recherche à la saisie elle est desactivée (si activée, la recherche rapide s'ouvre peu importe la touche saisie, ce qui n'est pas mon cas vu que l'option est desactivée)

En effet je pense que la meilleure soluce serait de recompiler le code pour supprimer ces 2raccourcis mais vla la galère si je dois me taper la manipe sur chaque mise à jour (et la mettre sur les 2machines que j'utilise)
6 Décembre 2007 19:14:09

NiahBoumPof is back a dit :
tu parles d'une fonctionalité, ca me pose plus de problemes qu'autre chose, vu ce que la recherche me sert :/ 

Et pour le coup du pointeur dans le champ de saisi j'ai deja essayé en effet (oui j'ai quand meme recherché avant de poster :D  desolé j'ai oublié de le preciser) et non rien a faire meme si le pointeur est dans le champ ca me le fait quand meme, jusqu'a la manip que j'ai detaillé plus haut.

Quand à l'option de recherche à la saisie elle est desactivée (si activée, la recherche rapide s'ouvre peu importe la touche saisie, ce qui n'est pas mon cas vu que l'option est desactivée)

En effet je pense que la meilleure soluce serait de recompiler le code pour supprimer ces 2raccourcis mais vla la galère si je dois me taper la manipe sur chaque mise à jour (et la mettre sur les 2machines que j'utilise)

nan mais sans deconner je sai spas comment tu fais, j'ai jamais eu le cas, et pourtant j'ai installé FF sur tout mon parc pro, depuis la 0.9.7 de FF :D 
6 Décembre 2007 19:36:43

En effet, y'a forcément quelque chose qui coince de ton côté car la recherche rapide ne s'active que lorsqu'on tape ' hors d'un champ de saisi. De la même manière que BackSpace te renvoit à la page précédente si t'es pas dans une zone de saisi.

Pourquoi ça le fait en toute occasion chez toi? Faudrait voir...
6 Décembre 2007 22:24:31

ah non aucun soucis avec les autres raccourci, juste avec ces 2fichus trucs de recherche rapide
et neo moi aussi j ai commencé FF avant la 1.0 et en effet jusqu a recement je n avais aucun soucis ca fait quelques versions (je pense depuis l implementation de ce truc ?) que ca me le fait.
6 Décembre 2007 23:08:47

Et donc, firefox en mode sans échec ca donne quoi?
30 Décembre 2007 08:44:05

Il y a quelques mois, j'ai eu le même souci ; attroce !
A la mise à jour de firefox, il avait disparu ; sauvé !

Mais là, il y a 30 minutes, je postais sur un forum et les apostrophes activées cette fonction (comment écrire en français sans les apostrophes ?)... Je savais que ça allait être long et difficile, mais pas du tout...

Sur google, en cherchant : "désactiver la recherche rapide" je suis tombé sur ce topic en premier, qui ne propose pas de solutions.

En ayant fait les 4 liens trouvés par google suivant, j'ai découvert celui-ci : fredvandaele
Il a résolu mon problème.

En résumé :
Pour désactiver la fonctionnalité recherche rapide de Firefox, il faut :
-Activer cette fonction en cliquant sur l'apostrophe hors d'une zone de saisie de texte.
-Cliquer sur ESC (ou echap) selon les claviers.


(C'est pour moi un grand souci qui se lève, quand je repense comment j'avais patiné la dernière fois...)

Bonne fin d'année ;) 
1 Janvier 2008 18:41:05

oooh mince j'avais completement zappé ce topic mes excuses pour ne pas avoir repondu :(  (j'ai eu à penser à d'autres problemes un chouilla plus importants :p )
donc, non le mode sans echec ne change rien. Par contre j'ai pu constater que selon les forums ca fonctionne plus ou moins bien. Par exemple avec les forums mesdiscussions.net aucun soucis contrairement à d'autres.
Et j'ai aussi remarqué que depuis la toute derniere mise à jour le soucis avait disparu surtout ^^
Sinon merci à awnorus pour le tips, au cas ou celà recommencerait. Et merci aux autres pour leur aide.
9 Janvier 2008 11:59:33

ah ba non ca me le refait à nouveau...apparement je vais devoir me contenter du bug qui desactive cette ********* de fonction (aller dans le menu option et en revenir)
9 Janvier 2008 12:03:37

Récupère la béta 3 ;) 
8 Février 2008 17:35:33

au passage, je ne retrouve plus le TU sur Firefox, alors je poste ici :o 

Depuis la 2.0.0.12, j'ai un correcteur d'ortho actif, malgré le fait d'avori desinstallé le dictionnaire machin dans els extension

faut bidouiller quoi dans about:config pour virer cette options à la con [:barbara gourde]

( * proof :o  )
8 Février 2008 18:15:24

Correcteur d'orthographe option à la con?
Pas sûr!
8 Février 2008 19:44:11

Outils / Options / Avancé / Onglet général / p'tite case à décocher :) 
11 Février 2008 11:36:54

nozz a dit :
Outils / Options / Avancé / Onglet général / p'tite case à décocher :) 

Merci ;) 
7 Février 2010 11:59:39

Super, merci! Je vais regarder ça, j'en ai bien besoin. J'ai jamais vu ce bug de ma vie, et de passage chez mes parents, je m'aperçois que leurs deux PC en souffrent. La plupart du temps ils marchent bien, mais parfois, sans raison apparente, l'apostrophe se met à ouvrir une recherche. Et ce n'est pas tout : j'ai l'impression que c'est accompagné d'autres bugs, comme les flèches qui ne marchent alors plus, ainsi que les touches Suppr, Fin, etc.

Comme leurs deux PC ont le même bugs, je me dis que ça vient peut-être de quelque chose qu'ils y ont installé. Ou de leur version de Windows (faut que je vérifie, si ça se trouve elle n'est pas légale, auquel cas je leur taperai sur les doigts; bouh, pas bien les parents! Le vol c'est mal!)

J'ai essayé la méthode de ton lien (ouvrir Outils->Téléchargements et le refermer), ça marche. Mais bon, on m'ôtera pas de l'idée que ce n'est pas une solution viable. Ils ont FF 3.5.7, je vais essayer de mettre à jour vers 3.6 pour voir si ça change quelque chose.

Anonyme
28 Février 2011 06:09:12

C'est tout bête pour désactiver la recherche rapide de Firefox

Outils - Options - Avancé - Onglet Général - décocher "lancer la recherche lors de la saisie de texte".

:) 

Et ça fonctionne très bien chez moi, terminée cette fonction plus embêtante qu'autre chose.